Drupal 8 solving composer problems like "Can only install one of ..."

I've been running into problems with composer several times now in combination with Drupal 8 projects. This blog post shares my problem solving solutions.

"Can only install one of ..." when updating

In many cases this can be resolved by clearing all folders from the "venor" directory and running
composer update PROJECT --with-dependencies again.
If that's not enough you can try to remove your composer.lock file and run the command above again.

Einordnung:

Comments

Post new comment

The content of this field is kept private and will not be shown publicly.

More information about formatting options