Drupal 7 Migrate Module: Migration not working with result "Processed 0 (0 created, 0 updated, 0 failed, 0 ignored)" even if there are entries to process

Some days ago I had to program a bigger import for a Drupal 7 Forum, including several hundreds of thousands of entries and comments. I decided to use the Drupal ‎Migrate‎ as helper for this import and it was a good decision!

Migrate‎ made things much easier and reduced the amount of custom import code.
Anyway I had a little problem during multiple import tests. After the first import test-runs worked, the import didn't run through anymore and resulted in the following message (no error):

Processed 0 (0 created, 0 updated, 0 failed, 0 ignored)

.

I first thought there was a mistake in my implementation, but it wasn't. The reason seems to lie deeper within ‎Migrate‎ and the solution is simple: You just have to reset that migration completely by removing it and re-including it again by using the

"Remove migration settings"

option.

After this hard reset everything worked fine again for me, without any other changes.

Kommentare

Kommentar hinzufügen

Der Inhalt dieses Feldes wird nicht öffentlich zugänglich angezeigt. Wenn Sie ein zulässiges Avatar mit Ihrer E-Mail-Adresse verknüpft haben, wird dieses als Avatar verwendet.

Weitere Informationen über Formatierungsoptionen

Aktualisieren Geben Sie die Zeichen ein, die Sie im Bild sehen. Geben Sie die im Bild dargestellten Zeichen ein; wenn Sie diese nicht lesen können, senden Sie das Formular ohne Eingabe ab, um ein neues Bild zu generieren. Groß-/Kleinschreibung wird nicht beachtet.  Switch to audio verification.